Messaging Degradation

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:10 CDT

Update

We continue to monitor for continued stability.
Posted Oct 20, 2025 - 16:41 CDT

Update

We are continuing to monitor for stability. We are still observing some latency in delivery but messages are being delivered successfully. We'll continue to monitor closely and update as needed.
Posted Oct 20, 2025 - 14:29 CDT

Monitoring

Our downstream carriers have identified an issue that impacted messaging delivery and latency. Recovery efforts are currently underway, however there may still be delays in message delivery. Our team will continue to monitor the situation closely. We'll provide another update in two hours.
Posted Oct 20, 2025 - 12:20 CDT
This incident affected: Messaging Services (Toll-Free SMS, Toll-Free MMS, Longcode SMS, Longcode MMS, Shortcode SMS, Message Delivery Receipts) and APIs.