Textel EU API Incident

Resolved

This incident has been resolved.
Posted May 16, 2025 - 12:05 CDT

Identified

We have identified an issue with our EU APIs, and we are working on a resolution.
Posted May 16, 2025 - 08:27 CDT
This incident affected: APIs.