International Message Latency

Resolved

This incident has been resolved.
Posted Oct 27, 2023 - 14:31 CDT

Investigating

We are currently experiencing message latency with international numbers. We are working directly with our carrier partner to resolve.
Posted Oct 27, 2023 - 13:50 CDT
This incident affected: Messaging Services (Toll-Free SMS, Toll-Free MMS, Longcode SMS, Longcode MMS, Shortcode SMS).